Your PAD won't charge? Having trouble turning your PAD on?
Try these troubleshooting tips:
Possible causes
- A damaged charging port on the Ingenico device or PAD
- A bad "Y" cable inside the case of the PAD
- Dirty charging ports on the Ingenico port or PAD port
- Incorrect power brick or cable: Charging will only work with an Apple 12w USB-A Brick and a Type A to Type C cable
- Damaged cable
- Overcharging of the device
Troubleshooting steps
- Restart the PAD
- Switch charging cables or power outlet
- Flip the USBC charging cable to the opposite side
- Plug the PAD in to charge and perform a restart
- Ensure the device has been charged for at least 30 minutes
Preventative actions
- Keep the PAD clean and away from areas with food or liquids
- Avoid bending the charging cables in a way that could damage them
- Take the case off the PAD for cleaning every now and then
- Inspect the ports and cables within the PAD to ensure they are in good condition
- Store the PAD devices in a safe place when not in use
- Use only the approved cables and power bricks provided for charging